Problema Module DLL ‘C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\isapi\spnativerequestmodule.dll’

Hace  un par de  días  tuve que  configurar un  servidor Sharepoint 2013 con un respectivo sitio pero al revisar que  el Portal del ESB no cargaba  después de que  días  atrás  estaba  funcionando sin problemas  mirando el Event View encontré este  error:

Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 3/22/2017 2:33:55 PM
Event time (UTC): 3/22/2017 6:33:55 PM
Event ID: 427a2fa568e6483daa0bd6964ae60e7b
Event sequence: 8
Event occurrence: 1
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/1/ROOT/ESB.Portal-1-131346812332787728
Trust level: Full
Application Virtual Path: /ESB.Portal
Application Path: C:\inetpub\wwwroot\ESB.Portal\
Machine name: MSPWVA-DOFMRS02

Process information:
Process ID: 22684
Process name: w3wp.exe
Account name: MSPWVA-DOFMRS02\SOAInstall

Exception information:
Exception type: WebException
Exception message: The request failed with HTTP status 503: Service Unavailable.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Microsoft.Practices.ESB.Portal.BizTalkOperationsService.Operations.Applications()
at Microsoft.Practices.ESB.Portal.PortalHelper.GetAllApplications()
at Microsoft.Practices.ESB.Portal.Lists.MySetting.renderApplicationSettings()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Request information:
Request URL: http://localhost/ESB.Portal/Reports/Reports.aspx?tzo=-4
Request path: /ESB.Portal/Reports/Reports.aspx
User host address: 127.0.0.1
User: MSPWVA-DOFMRS02\SPAdmin
Is authenticated: True
Authentication Type: Negotiate
Thread account name: MSPWVA-DOFMRS02\SOAInstall

Thread information:
Thread ID: 15
Thread account name: MSPWVA-DOFMRS02\SOAInstall
Is impersonating: False
Stack trace: at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Microsoft.Practices.ESB.Portal.BizTalkOperationsService.Operations.Applications()
at Microsoft.Practices.ESB.Portal.PortalHelper.GetAllApplications()
at Microsoft.Practices.ESB.Portal.Lists.MySetting.renderApplicationSettings()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
Custom event details:

Como indicio del problema tenía  que estuve configurando Sharepoint  del cual tambien aparecia  el siguiente error en el Event Viewer:

The Module DLL ‘C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\isapi\spnativerequestmodule.dll’ could not be loaded due to a configuration problem. The current configuration only supports loading images built for a x86 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture mismatch error, see http://go.microsoft.com/fwlink/?LinkId=29349.

Luego de buscar  mucho encontré esta solución:

Al parecer  es  un bug  pero  hasta  el momento es lo  que  parece.

Ejecutar este comando  con privilegios de administrador:

appcmd.exe set config -section:system.webServer/globalModules /[name=’SPNativeRequestModule’].preCondition:integratedMode,bitness64

Luego de  esto  has  un IISReset o reuniciar el IIS y  todo correra con normalidad

Fuente:http://bartwullems.blogspot.com.co/2013/08/sharepoint-error-module-dll-filescommon.html

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s